Videoconferencing Units Compatible with Videxio Subscriptions

Supported Cisco Devices

Model Minimum Supported Software Version Recommended Software Version
MX-Series TC4.2
CE8.0
CE8.2.1 or newer
SX-Series TC5.0
CE8.0
CE8.2.1 or newer
DX-Series CE8.2 CE8.2.1 or newer
C-Series TC4.2 TC7.3.4 or newer
EX-Series TC4.2 TC7.3.4 or newer
E20 TE4.0 TE4.1.7
MXP F8.2 F9.3 or newer
Spark Room Kit CE9.0.1 Latest

Note: Using older firmware versions may produce some functionality limitations as the Videxio Service continues to evolve.  It is recommended that current firmware versions be used to take advantage of latest device features and security patches.

Supported Huawei Devices

Model Minimum Supported Software Version Recommended Software Version
TE 10 series V500R003C20SPC200 V500R003C30SPC100
TE 20 series V500R003C00SPC200 V500R003C30SPC100
TE 30 series V500R002C00SPC600 V500R002C00SPCb00
TE 40 series V500R002C00SPC600 V500R002C00SPCb00
TE 50 series V500R002C00SPC600 V500R002C00SPCb00

 

Links to download Huawei software:

English -> Select other TE-Series models from the TE30 pulldown menu

Chinese -> Select other TE-Series models from the TE30 pulldown menu

Note: Using older firmware versions may produce some functionality limitations as the Videxio Service continues to evolve.  It is recommended that current firmware versions be used to take advantage of latest device features and security patches.

Supported Polycom Devices

Model Minimum Supported Software Version Recommended Software Version
RealPresence Debut* 1.0.0 1.2.x
RealPresence Group 4.0.2 6.1.2
HDX 3.0.5 3.1.11
RealPresence Trio 8500/8800 # 5.7.1 5.7.1

 *RealPresence Debut supports automatic activation with the subscription tied to the serial number 

#Trio requires manual registration with a configuration template, please see this article

Note: Using older firmware versions may produce some functionality limitations as the Videxio Service continues to evolve.  It is recommended that current firmware versions be used to take advantage of latest device features and security patches.

Supported Yealink Devices

Model Minimum Supported Software Version Recommended Software Version
VC200 80.32.0.44 80.32.0.44 or newer
VC500 62.32.0.44 62.32.0.44 or newer
VC800 62.32.0.44 62.32.0.44 or newer
VC880 62.32.0.44 62.32.0.44 or newer

Note: Using older firmware versions may produce some functionality limitations as the Videxio Service continues to evolve.  It is recommended that current firmware versions be used to take advantage of latest device features and security patches.

Supported Ricoh Devices

Model Minimum Supported Software Version Recommended Software Version
P3500M TBA TBA
 
 
 
 
 
Note: Using older firmware versions may produce some functionality limitations as the Videxio Service continues to evolve.  It is recommended that current firmware versions be used to take advantage of latest features and security patches.
Was this article helpful?
2 out of 2 found this helpful
Have more questions? Submit a request

Comments

0 comments

Please sign in to leave a comment.